Radware Cloud WAF Incident Notification

Incident Report for Radware Cloud WAF Status Page

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 05:12 UTC

Monitoring

All services remain stable, we will continue to monitor. No issues were thus far detecting stemming directly from Radware.
Posted Jan 21, 2026 - 19:32 UTC

Investigating

Radware Cloud WAF service experienced a service impacting event which may have caused temporary degredation in Ashburn and Chicago PoPs. Radware has detected temporary Public Internet instability impacting multiple ISPs and cloud service providers between the hours of 16:30 UTC and 17:15 UTC today. This does not appear specific to Radware at this time.

Radware is monitoring the situation and we will provide updates as they are received.


For additional questions please contact us via the support portal at https://support.radware.com/
Posted Jan 21, 2026 - 18:30 UTC
This incident affected: The Americas (North America (Ashburn), North America (Chicago)).