Radware Cloud WAF Incident Notification

Incident Report for Radware Cloud WAF Status Page

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 14:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2025 - 14:12 UTC

Investigating

Radware Cloud WAF service is currently experiencing a service impact event in the regions shown below:

North America (Ashburn)
North America (Chicago)
North America (Toronto)

Radware is working to restore service as soon as possible and apologies for any inconvenience that may cause.

For additional questions please contact us via the support portal at https://support.radware.com/
Posted Jul 31, 2025 - 12:57 UTC
This incident affected: The Americas (North America (Ashburn), North America (Chicago), North America (Toronto)).