Radware Cloud WAF Portal - Self-Service Portal Issue Affecting MAA and BOM Applications

Incident Report for Radware Cloud WAF Status Page

Resolved

This incident has been resolved.
Posted May 14, 2026 - 10:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2026 - 10:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2026 - 09:57 UTC

Investigating

Radware is currently investigating a self-service issue affecting applications utilizing MAA and BOM.
Impact: Intermittent availability and accessibility issues within the self-service portal applications.
No impact on customer traffic or protection services — mitigation and security services remain fully operational.

Radware is actively working to restore full service functiona

Radware is working to restore service as soon as possible and apologies for any inconvenience that may cause.
For additional questions please contact us via the support portal at https://support.radware.com/
Posted May 14, 2026 - 07:36 UTC
This incident affected: Global Cloud (Global Cloud (Portal)).