Radware Cloud WAAP Incident Notification

Incident Report for Radware Cloud WAF Status Page

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 04:00 UTC

Monitoring

This issue is currently under monitoring. No further impact is anticipated.
Posted Feb 23, 2026 - 21:56 UTC

Investigating

Radware Cloud WAF service experienced a service impact event. Between 18:50-1900 UTC Cloud WAAP a subset of applications in the below region may have experienced high latency or degredation.

Frankfurt/Amsterdam

Radware is investigating the interruption and apologized for any inconvenience that may cause.

For additional questions please contact us via the support portal at https://support.radware.com/
Posted Feb 23, 2026 - 20:08 UTC
This incident affected: Europe (Europe (Amsterdam), Europe – Frankfurt (Amsterdam)).